TablePro

"ТаблицаПро" - простая и удобная база данных для дома и офиса. Быстрый и мощный поиск, экспорт в различные форматы, печать, сортировка по всем полям, настройка пользовательского интерфейса, очень быстрая загрузка и обработка огромного количества записей. Программу используют для хранения телефонных справочников, таблиц сотрудников и клиентов, картотек, видеотек, прайс-листов, LOG-файлов, файлов статистики и др.


Возможности и преимущества

  • ТаблицаПро занимает очень мало места, не требует инсталляции, не создает файлов вне своего каталога, не использует системный реестр, может запускаться даже с компакт-диска или дискеты.
  • В программе не используются компоненты баз данных, она "легкая" и мгновенно запускается даже на слабых компьютерах.
  • Таблицы могут содержать сотни миллионов записей.
  • Поддерживаются картинки в ячейках, гиперссылки, перенос слов, вычисления по формулам, последовательная сортировка, группировка столбцов.
  • Поддерживается экспорт во множество популярных форматов. Если вы решите отказаться от использования программы, вы можете экспортировать свои данные, чтобы продолжать использовать их в других программах.
  • Таблицы можно защищать паролями.
  • Мощные возможности поиска и автоматизированная обработка записей.
  • Таблицы хранятся в распространенном формате CSV, поэтому их можно открывать и во многих других редакторах, например в Excel'е или в обычном Блокноте. Программу можно использовать просто как конвертер из формата CSV в другие, программа достаточно эффективно определяет символ-разделитель в CSV-файлах.

И еще многое-многое другое умещается в очень маленькой программе "ТаблицаПро"!


Главное окно

После открытия любой таблицы в главном окне программы будут отображены три списка: Все, Найденные и Выбранные. Первый список содержит все записи из открытой таблицы. Второй служит для отображения результатов поиска. В третьем показываются выбранные записи. Меню для работы с каждым из списков вызывается нажатием Ctrl+Пробел или щелчком правой кнопкой мыши на списке.

Мышью можно менять размеры столбцов. Двойным щелчком на разделителе между столбцами размер столбца устанавливается автоматически. Чтобы упорядочить записи по алфавиту (по возрастанию), достаточно щелкнуть мышью на заголовке столбца. При повторном щелчке записи будут упорядочены в обратном порядке. Также поддерживается последовательная сортировка записей.

Программа автоматически распознает данные, находящиеся в ячейках таблиц, и отображает их в соответствующем стиле. Например, числа располагаются по правому краю ячеек. Ссылки на web-сайты, адреса e-mail, пути к файлам и каталогам отображаются в стиле гиперссылок. Программа также распознает даты - это учитывается при сортировке записей.


Меню

Ниже приведено описание команд главного меню.

Файл

Новый...
Открыть...
Выбрать таблицу...
Сохранить...
Сохранить как...
Закрыть
Выход

Вид

Панель инструментов
Разделять на секции

Запись

Добавить...
Изменить...
Удалить
Быстрый поиск...
Обычный поиск...
Расширенный поиск...
Все
Выбрать все
Найденные
Выбрать все
Обратить список
Очистить список
Выбранные
Вернуть все
Обратить список
Удалить все

Сервис

Таблица...
Импорт...
Экспорт...
Печать...
Операции...
Параметры...

?

Помощь
О программе...


Вопросы и ответы

Как добавить столбец

Выберите в меню Сервис команду Таблица.... Отобразится окно со списком столбцов таблицы. Нажмите на кнопку Добавить столбец.

Как вычислить сумму значений по одному из столбцов

Выберите в меню Сервис команду Таблица..., щелкните на категории Информация - Вычисления. В правом поле будут показаны различные вычисления по каждому из столбцов. Там же отображаются вычисления для списков Найденные и Выбранные, если эти списки не пусты.

Как изменить свойства столбца

Нужно выбрать в меню Сервис команду Таблица..., а затем в появившемся окне дважды щелкнуть на названии требуемого столбца. Отобразится окно, в котором можно изменять свойства столбца.

Как показывать картинки в ячейках таблицы

Для этого в свойствах одного из столбцов установите свойство Тип равным Картинка, а свойство Редактор в карточке равным Диалог выбора файла. После этого при добавлении или редактировании записи можно будет выбирать файл, из которого будет загружаться картинка.

Как сделать перенос слов в ячейках

Установите в свойствах нужного столбца свойство Тип равным Текст с переносом слов. Можно также установить свойство Редактор в карточке равным Многострочный текст.

Как удалить большое количество записей из таблицы

Сначала поместите те записи, которые нужно удалить, в список выбранных записей. Это можно сделать одним из следующих способов: либо выделять удаляемые записи и нажимать клавишу Ins, либо одним из видов поиска найти все удаляемые записи, а затем выбрать команду Запись - Найденные - Выбрать все. Когда в списке Выбранные будут собраны все записи, которые нужно удалить, выберите команду Запись - Выбранные - Удалить все.

Как найти в одном столбце все числовые значения в определенном интервале (например, от "1" до "5")

Выберите команду Запись - Расширенный поиск.... Появится окно мастера расширенного поиска. На странице "Исходные данные" выберите поиск по значениям и нажмите Далее. Укажите в двух полях Столбец один и тот же столбец (в котором нужно найти числа). В одном из полей Условие выберите строку >= число/дата/время, а в соответствующем поле Значение введите "1". Аналогично, во втором поле Условие выберите <= число/дата/время и введите "5". Следуйте дальнейшим шагам мастера.

Как вставлять "переводы строк" в полях

Начиная с версии 3.20, программа поддерживает переводы строк в значениях полей. Используйте в карточке клавиши Ctrl+Enter для перевода строки (у столбца свойство Редактор в карточке должно быть равным Многострочный текст).

Зачем нужны макросы в программе

Представьте, что нужно ежедневно заполнять таблицу "Заказы", в которой есть столбец "Дата добавления заказа". Чтобы каждый раз не вводить текущую дату, можно один раз задать такой макрос для столбца, чтобы дата заполнялась сама. Это ускорит работу. См. макросы.

Как выполнять последовательную сортировку

При щелчке мышью в таблице на имени одного из столбцов программа упорядочивает записи, сравнивая значения записей в этом столбце. Если значения двух записей совпадают, то последовательно сравниваются значения в других полях, начиная с самого левого столбца и пропуская столбец сортировки. Для выполнения особого порядка прохода по столбцам, используйте клавишу Shift. Например, если в таблице находится множество столбцов, среди которых есть "Категория" и "Имя", и нужно упорядочить по категориям, а внутри категорий по именам, то выполняют следующее: сначала просто упорядочивают по категориям, а затем, удерживая клавишу Shift, упорядочивают по именам. Такую особую последовательность сортировки можно задать хоть для всех столбцов таблицы. Чтобы сбросить последовательность, нужно упорядочить записи по любому из столбцов, не удерживая клавишу Shift.

Как выводить числа в ячейках в определенном формате

Для этого создайте виртуальный столбец с формулой, содержащей метод Format. В этом методе в качестве параметра нужно указать столбец, в котором хранятся числа. Например, если числа находятся во втором столбце, то формула может выглядеть так: Format("#,##0.00", #2). См. формулы.


Разное

Сочетания клавиш
Формулы
Макросы
Командная строка
Файлы
Ограничения
Программы


О программе

Программа существует с 2000 года. Изначально называлась "Телефонный справочник", т.к. создавалась для хранения номеров телефонов. Затем несколько раз сменила свое название и теперь называется "ТаблицаПро".

Адрес в Internet: http://zgsprojects.narod.ru - ищите здесь новые версии программ.

Электронная почта: zgsprojects@narod.ru - обязательно отправляйте вопросы и предложения.

Автор: Жмулевский Григорий.

Благодарю за использование программы!


Файл - Новый

Чтобы создать новую таблицу, выберите команду Новый... в меню Файл или просто нажмите Ctrl+N (New). При этом появится окно Создание таблицы.

В окне нужно перечислить названия столбцов, которые должны быть в таблице. По умолчанию программа предлагает 3 столбца с именами: Column1, Column2, Column3. Названия столбцов могут содержать любые символы. При необходимости можно также установить опции таблицы, расположенные в правой части окна.

После нажатия кнопки OK будет создана пустая таблица. Для добавления новых записей используйте клавишу F5. Чтобы изменить столбцы или опции таблицы, выберите команду Таблица... в меню Сервис.

См. также
Меню


Файл - Выбрать таблицу

При выборе команды Выбрать таблицу... из меню Файл, появляется диалоговое окно, в котором отображается список таблиц. Это диалоговое окно появляется также по клавише F4.

Окно "Выбор таблицы" служит для открытия таблицы, но, в отличие от команды Открыть... из меню Файл, в списке отображаются только таблицы из рабочих каталогов. Полужирным выделяется таблица, которая была открыта в прошлый раз. Чтобы открыть одну из таблиц, дважды щелкните мышью на ее имени. Если таблиц в списке очень много, то удобно пользоваться полем, расположенным над списком. Для быстрого выбора таблицы нужно ввести в этом поле первые буквы из имени искомой таблицы или пользоваться клавишами Up и Down. Дополнительные возможности предоставляет всплывающее меню по правой кнопке мыши.

В параметрах программы можно настроить пути к рабочим каталогам.

См. также
Меню
Меню - Сервис - Параметры - Основные


Запись - Добавить

При выборе команды Добавить... в меню Запись появляется окно карточки.

Это окно служит для добавления записей в таблицу. В окне нужно заполнить поля новой записи. Поля могут отображаться по-разному, в зависимости от настроек столбцов и параметров программы. После заполнения полей нажмите Enter для добавления записи.

В программе многое сделано для того, чтобы максимально упростить и ускорить процесс добавления новых записей:

  • автоматическое заполнение полей типа Счетчик;
  • автоматическое заполнение полей значением по умолчанию (поддерживается заполнение текущей датой, временем);
  • если диалог был вызван с зажатой клавишей Shift, то поля будут заполнены значениями записи, выделенной в главном окне;
  • переход между полями с помощью клавиш Up и Down, Ctrl+Up и Ctrl+Down;
  • раскрытие списков с ранее введенными значениями (можно использовать клавиши F4 или Alt+Down, а можно установить автоматическое раскрытие в параметрах);
  • перебор ранее введенных значений клавишами PgUp и PgDown;
  • переход между полями при щелчке мышью на их названиях (автоматически выделяется текст в поле);
  • открытие всплывающего меню при щелчке правой кнопкой мыши на названии поля (например, чтобы быстро скопировать или заменить текст);
  • перед добавлением записи программа проверят возможность добавления, исходя из опций таблицы;
  • после добавления записи осуществляется переход к добавлению новой (можно отключить в параметрах программы);
  • если диалог был вызван с зажатой клавишей Alt, то новые записи будут вставляться перед выделенной записью в главном окне;

См. также
Меню
Меню - Сервис - Параметры - Карточка


Запись - Изменить

Окно карточки для редактирования записи вызывается при выборе команды Изменить... в меню Запись. Окно служит для редактирования текущей выделенной записи. Это окно также вызывается нажатием Enter. Некоторые поля в карточке имеют кнопки для раскрытия списков с ранее введенными значениями. Для раскрытия этих списков используйте клавишу F4 или комбинацию Alt+Down. Списки также могут раскрываться автоматически при печатании, если в параметрах программы установлена соответствующая опция. Для перехода между полями используйте клавиши Up и Down. Можно щелкать мышью по названиям полей, тогда фокус ввода будет перемещаться к соответствующему полю, а текст в поле будет выделяться. Для многострочных полей можно вставлять "переводы строк" с помощью комбинации Ctrl+Enter.

См. также
Меню
Меню - Запись - Добавить
Меню - Сервис - Параметры - Карточка


Запись - Расширенный поиск

Расширенный поиск вызывается комбинацией Ctrl+W (Wide). Данный вид поиска не только предоставляет дополнительные возможности поиска данных, но также позволяет выполнить некоторые действия с результатом (например, из тех записей, что находятся в списке Найденные, убрать записи, которые будут найдены сейчас).

Возможности расширенного поиска: поиск по любому из списков (Все, Найденные, Выбранные), поиск по длине строки, по маске, с учетом регистра, по началу или окончанию строки, по исключающей строке, по примерному (неточному) совпадению, поиск повторяющихся значений и др.

См. также
Меню
Меню - Сервис - Параметры - Поиск


Запись - Быстрый поиск

Окно быстрого поиска вызывается клавишей F3.

Нужно ввести всего одно значение. Поиск выполняется по всем записям и в каждом столбце. Поиск по части слова, регистр написания неважен. Все найденные записи собираются в список Найденные. Искомая строка выделяется в таблице цветом. В параметрах программы есть некоторые настройки для поиска. Например, можно включить возможность автоматического перехода на страницу Найденные после поиска.

См. также
Меню
Меню - Сервис - Параметры - Поиск


Запись - Обычный поиск

Обычный поиск вызывается комбинацией Ctrl+F (Find). Действует, как и в большинстве аналогичных программ. Нужно указать одно или несколько значений (можно также выбрать значения из списков).

Поиск производится по условию И, т.е., если указаны значения для двух столбцов, то будут найдены записи, в которых присутствуют оба этих значения, а не только одно из них. Поиск по части слова, регистр написания неважен. Все найденные записи собираются в список Найденные. Искомая строка выделяется в таблице цветом. Для дополнительных возможностей поиска следует использовать расширенный поиск.

См. также
Меню
Меню - Сервис - Параметры - Поиск


Сервис - Экспорт

С помощью экспорта можно сохранить таблицу или часть таблицы в файлы различных форматов. Эти файлы можно будет открывать в других программах.

Чтобы вызвать окно экспорта, выберите в меню Сервис команду Экспорт... или нажмите Ctrl+E. В появившемся окне нужно выделить источник (все, найденные или выбранные записи), отметить экспортируемые столбцы, а также выбрать формат экспорта. По умолчанию выделен тот источник, страница которого открыта в главном окне программы.

В данной версии программы поддерживаются следующие форматы экспорта:

Формат | Примечание | Расширение
CSV | Используется разделитель, выбранный в параметрах программы (в категории экспорта) | csv
TXT (Tab) |  | txt
HTML |  | html, htm
Excel | Не выполняется автоматический подбор ширины столбцов | xls
Excel (OLE) | Требуется наличие установленной программы MS Excel | xls
INI |  | ini
XML |  | xml
Word (OLE) | Требуется наличие установленной программы MS Word | doc
DBF |  | dbf

После нажатия кнопки Экспорт... программа предложит ввести имя для создаваемого файла. Программа запоминает отмеченные столбцы и формат экспорта, чтобы в следующий раз не нужно было устанавливать эти параметры заново. Программа всегда предлагает имя для создаваемого файла. В параметрах программы можно включить возможность, чтобы предлагаемое имя содержало дату и время создания файла (это удобно при частом выполнении экспорта).

См. также
Меню
Меню - Сервис - Параметры - Экспорт


Сервис - Операции

Мастер операций вызывается комбинацией клавиш Ctrl+R. Этот мастер предназначен для обработки большого количества записей. Мастер предоставляет следующие виды операций:

Заполнить

Заполнить одно или несколько полей каждой записи некоторым значением.

Вставить

Вставить в определенную позицию одного из полей каждой записи некоторое значение.

Заменить

Заменить часть одного из полей каждой записи некоторым значением.

Удалить

Очистить одно из полей каждой записи или удалить его часть.

Верхний регистр

Привести к верхнему регистру одно из полей каждой записи.

Нижний регистр

Привести к нижнему регистру одно из полей каждой записи.

Обратить регистр

Сменить верхний регистр на нижний (или наоборот) в одном из полей каждой записи.

ANSI -> OEM

Конвертировать поля записей в OEM-формат.

OEM -> ANSI

Конвертировать поля записей в ANSI-формат.

Удалить крайние пробелы

Удалить крайние пробелы в определенных полях каждой записи.

См. также
Меню


Сервис - Параметры

Программа имеет множество различных параметров, с помощью которых можно настраивать ее функциональность и внешний вид. Окно параметров вызывается с помощью команды Параметры... в меню Сервис.

В левой части окна отображается список категорий параметров, а справа от этого списка - все параметры в выбранной категории. С помощью кнопки Применить можно без закрытия окна просматривать, как изменение тех или иных параметров влияет на внешний вид программы.

Ниже приведено описание параметров по категориям:

Основные
Списки
Заголовки
Поиск
Карточка
Экспорт
Печать
Инструменты
Дополнительно

См. также
Меню


Сервис - Параметры - Карточка

Здесь указано несколько опций для карточки. Карточка - это окно, которое служит для отображения всех полей одной записи. Карточка может быть открыта в нескольких режимах: для добавления, просмотра, редактирования и поиска записей.

Добавление записей в одном окне

Если эта опция выключена, то сразу после добавления новой записи окно карточки будет закрываться. А если опция включена, то после добавления записи поля в окне будут очищены и программа предложит добавить следующую запись.

Скрывать кнопки

Отображать кнопку выбора из списка только у того поля, которое сфокусировано или над которым находится курсор мыши.

Раскрывать списки при печатании

Эта опция позволяет повысить скорость набора значений в полях, автоматически раскрывая список с предлагаемыми значениями. Если эта опция выключена, то раскрыть список можно с помощью клавиши F4 или комбинации Alt+Down.

Показывать виртуальные столбцы

Если эта опция включена и в таблице есть виртуальные столбцы, то программа будет отображать поля ввода для виртуальных столбцов (без возможности редактирования).

Относительные имена файлов

Эта опция действует для тех столбцов, у которых свойство Редактор в карточке установлено в Диалог выбора файла. Опция определяет, какое имя выбранного файла (после открытия диалога) должно быть установлено в поле: относительное или полное.


Сервис - Параметры - Экспорт

Параметры, используемые при экспорте таблицы или части таблицы.

Предлагаемое имя файла

В этом поле указывается имя файла, которое предлагается при сохранении файла экспорта (через меню Сервис - Экспорт...). Если вы часто используете экспорт в программе, укажите в этом поле наиболее удобное имя файла. Имя может быть коротким (например, "Export") или содержать полный путь (например, "C:\MyFiles\Export"). В любом случае, в этом имени не должно указываться расширение файла. Предлагаемое имя файла поддерживает макросы, например, вместо "$Year$/$Month$/$Day$", будет автоматически подставляться текущая дата. Следует учитывать, что некоторые символы (например, ":") недопустимы в именах файлов. См. макросы.


Table Pro

Сервис - Параметры - Списки

Эти параметры относятся к отображению содержимого таблиц (списков записей). Здесь можно установить шрифт, отображение горизонтальных/вертикальных линий и др. параметры.

Показывать картинки

Если эта опция включена, и какой-либо столбец таблицы имеет тип Картинка, то программа будет загружать и отображать картинки в ячейках этого столбца. Поддерживаются картинки следующих форматов: JPEG, JPG, BMP, ICO, EMF, WMF.

Отображать '+' и '-' как значки

Программа может отображать зеленый значок "+" или красный "-", если значением ячейки является соответствующий символ ("+" или "-"). Это удобно для более быстрого восприятия содержимого таблицы.

Показывать подсказки

Следует ли показывать подсказку над ячейкой, если ее значение не видно полностью (для картинок - следует ли показывать подсказку с именем файла картинки).

Ссылки http и www, Ссылки e-mail

При включении этих опций программа будет автоматически распознавать (и отображать как гиперссылки) www-адреса и e-mail-адреса. В любой ячейке может быть текст, содержащий множество гиперссылок.


Table Pro

Сервис - Параметры - Основные

Рабочий каталог

Рабочий каталог - это путь к папке, в которой хранятся файлы ваших таблиц (CSV-файлы). Рабочий каталог используется в программе для того, чтобы быстро выбирать файл из списка, а не пользоваться стандартным диалогом открытия файла. По умолчанию рабочим каталогом является та папка, из которой запускается программа. Начиная с версии 3.25, в программе поддерживаются сколько угодно рабочих каталогов.

Таблица при запуске

При выборе значения Спрашивать, программа при каждом запуске будет отображать окно с содержимым рабочего каталога. При выборе значения Запомнить последнюю, программа при запуске будет открывать ту таблицу, которая редактировалась последний раз.

Разделитель

Выбранный из списка разделитель используется при сохранении файлов таблиц. При загрузке этих файлов программа определяет разделитель автоматически (программа пытается прочесть файл, подставляя разделители по очереди, но первым подставляется выбранный в этом списке разделитель).

Использовать выбор и страницу "Выбранные"

Отключите эту опцию, если страница "Выбранные" совсем не используется в работе. При отключенной опции также будут скрыты соответствующие пункты в меню.


Сервис - Параметры - Заголовки

Эти параметры влияют на отображение "шапок" таблиц. Можно установить или отключить перенос слов в заголовках, разделение столбцов на группы (группы определяются через символ ":"), отображение подсказок (название и описание столбца). А с помощью кнопки Шрифт можно изменить шрифт для заголовков.


Сервис - Параметры - Дополнительно

В данную категорию параметров вынесены расширенные параметры, которые редко используются большинством пользователей.

Запоминать выделение в таблицах

При закрытии таблицы запоминать индекс выделенной записи и позицию полос прокрутки, а при следующем открытии таблицы восстанавливать эти значения. Если эта опция выключена, то при открытии таблицы будет всегда выделяться первая (верхняя) запись. По умолчанию эта опция включена.

Сообщать о режиме просмотра

При открытии таблицы программа проверяет, доступен ли файл таблицы для записи, и, если это не так, то выдает соответствующее сообщение. Эту опцию рекомендуется отключить, если предполагается использовать CSV-файлы, записанные на компакт-диск.

Оборачивать все поля в кавычки

Эта опция действует при сохранении таблиц. Опцию нужно включить, если по каким-либо причинам требуется, чтобы в CSV-файле таблицы каждое значение было "обернуто" в кавычки. По умолчанию эта опция отключена, и программа "оборачивает" в кавычки только те значения, для которых это требуется.

Показывать прогресс при продолжительных операциях

Следует ли отображать окно прогресса при выполнении операций, если они занимают продолжительное время. Действует для большинства операций (загрузка, поиск и др.). При выполнении сортировки прогресс не отображается.

Показывать значки в меню

Следует ли отображать значки в главном меню программы, а также во всех всплывающих меню.

Показывать начальные страницы в мастерах

Если эта опция отключена, то во всех мастерах (Расширенный поиск, Операции) не будет отображаться страница приветствия, программа автоматически перейдет к следующей странице.

Добавлять значения полей в e-mail

При нажатии мышью в таблице на e-mail-адресе появляется окно создания нового письма. Если эта опция включена, то в текст нового письма будут вставлены все поля выделенной записи.


Сервис - Параметры - Печать

Показывать картинки

Следует ли печатать картинки (которые отображаются в таблице). Если опция выключена, то вместо картинок будут печататься имена файлов картинок.

Показывать сетку

Следует ли печатать вертикальные и горизонтальные линии для разделения столбцов и строк.

Вставлять заголовок

Следует ли вставлять названия столбцов таблицы при печати. Названия столбцов выделяются жирным.

Режим карточки

Если эта опция включена, то каждая запись будет печататься в виде отдельной карточки, где в левом вертикальном столбце отображаются имена полей, а в правом - значения. Иначе все записи будут печататься в одной таблице. Рекомендуется включить эту опцию, если столбцов в таблице много, а записей мало.


Сервис - Параметры - Поиск

Открывать страницу "Найденные" после поиска

Если эта опция включена, то после выполнения любого поиска (быстрый, обычный или расширенный) станет активной страница Найденные. Если опция выключена, то активной останется страница Все, а первая найденная в ней запись будет выделена.

Хранить историю результатов

По умолчанию на время работы программы списки найденных записей запоминаются, чтобы к ним можно было вернуться с помощью скрытых команд отображения предыдущего и следующего результата. Если в этих командах нет необходимости или нужно очень экономить оперативную память, то отключите эту опцию.

Сообщать о пустом результате

Если после поиска не было найдено ни одной записи, то сообщить об этом.

Сообщать об успешном результате

Если поиск оказался успешным, то сообщить, сколько записей было найдено.

Сбрасывать условия предыдущего поиска

Для расширенного поиска эта опция не действует.

Использовать слепой поиск

Слепой поиск используется в главном окне программы, когда при наборе пользователем искомой строки на клавиатуре программа сразу выделяет запись, содержащую эту строку. С помощью данной опции этот вид поиска можно отключить.


Сервис - Параметры - Инструменты

Эта категория параметров служит для настройки панели инструментов (верхняя панель с кнопками в главном окне программы). Левый список содержит все команды, которые могут быть размещены на панели инструментов. А в правом списке находятся те команды, которые уже размещены. Чтобы добавить кнопку на панель инструментов, перетащите мышкой соответствующую команду из левого списка в правый. Чтобы убрать кнопку с панели инструментов, перетащите соответствующую команду из правого списка в левый. Порядок расположения команд внутри правого списка можно менять, перетаскивая их мышью. В правом списке можно также использовать пункт "(Разделитель)" для визуального разделения команд на группы.


Сервис - Печать

Чтобы распечатать таблицу или часть таблицы на принтере, вызовите команду Печать... в меню Сервис или нажмите Ctrl+P (Print). Появится диалоговое окно Печать. В нем нужно выделить источник (все, найденные или выбранные записи), а также отметить, какие из столбцов следует распечатать. По умолчанию выделен тот источник, страница которого открыта в главном окне программы.

Для запуска печати нажмите кнопку Печать...

На самом деле программа не напрямую печатает записи. Выполняется экспорт в формате HTML во временный файл, а затем программа просит операционную систему распечатать этот файл. Поэтому результат печати может отличаться в зависимости от операционной системы и Интернет-браузера. Программа запоминает для каждой таблицы, какие из столбцов были отмечены для печати, чтобы в следующий раз не нужно было отмечать столбцы заново.

В параметрах программы можно установить шрифт печатаемых данных, а также другие опции печати.

См. также
Меню
Меню - Сервис - Параметры - Печать


Сервис - Таблица

При выборе команды Таблица... в меню Сервис появляется окно, в котором можно просматривать и изменять настройки текущей таблицы (параметры столбцов, опции, пароль и др.). Обратите внимание, что у окна нет кнопки Отмена, и все вносимые изменения (например, переименование столбцов) сразу же отображаются в главном окне программы.

Столбцы
Опции
Информация

См. также
Меню


Сервис - Таблица - Столбцы

Чтобы отобразить редактор столбцов из главного окна программы, выберите команду Таблица... из меню Сервис или нажмите Ctrl+T. Редактор позволяет добавлять, удалять, перемещать, скрывать (отображать) столбцы, изменять их названия и другие свойства. Все изменения столбцов сразу отображаются в главном окне программы. В списке показываются столбцы текущей таблицы.

Чтобы не показывать какой-либо из столбцов, уберите галочку напротив его названия. Столбцы в списке можно перемещать мышью или с помощью кнопок со стрелками. Для изменения свойств столбца, выделите требуемый столбец и нажмите кнопку Изменить.... Чтобы разделять столбцы на группы, используйте в их названиях символ ":" (двоеточие). Например, столбцы "Компания:Название" и "Компания:Город" будут образовывать группу столбцов "Компания" с двумя подчиненными столбцами "Название" и "Город". Такие столбцы должны находиться в списке рядом друг с другом.

Виртуальные столбцы - это столбцы, значения которых не хранятся в таблице. Каждый виртуальный столбец содержит формулу для вычисления своих значений. См. формулы. Виртуальные столбцы могут использоваться не только для вычислений, но и для проверки введенных значений.

См. также
Меню - Сервис - Таблица


Сервис - Таблица - Столбцы - Изменить

Окно служит для установки свойств столбца.

Название

Название столбца, например, "ФИО", "Телефон" и т.д.

Выравнивание

Горизонтальное положение текста в ячейках столбца. Если выбрано значение Автоматически, то текстовые значения будут располагаться по левому краю, числа - по правому, а картинки - по центру.

Описание

Подробное описание столбца, например, "ФИО клиента", "Мобильный или домашний телефон с кодом города" и т.д. Описание столбца отображается во всплывающих подсказках почти во всех окнах программы (карточка, окно экспорта и т.д.), если подвести мышь к названию столбца.

Тип

Тип столбца (влияет на отображение и функциональность полей):
  • Общий - обычный столбец.
  • Счетчик - столбец с порядковыми номерами записей, при добавлении новых записей значение в этом столбце автоматически заполняется.
  • Файл - столбец с именами файлов, отображаемых в виде гиперссылок (значения в этом столбце должны содержать полные имена файлов либо относительные к имени файла таблицы).
  • Картинка - столбец с именами файлов картинок. Программа загружает из файлов картинки и отображает их в ячейках столбца (значения в этом столбце должны содержать полные имена файлов либо относительные к имени файла таблицы). Поддерживаются картинки форматов JPG, JPEG, BMP, ICO, EMF, WMF.
  • Текст с переносом слов - в столбце такого типа выполняется автоматический перенос слов.

Редактор в карточке

Вид поля, которое отображается в окне карточки при редактировании записи:
  • Поле со списком - поле с кнопкой для раскрытия ниспадающего списка, из которого можно выбрать одно из ранее введенных значений.
  • Поле - простое поле без кнопок.
  • Диалог выбора файла - поле с кнопкой, при нажатии на которую отображается стандартный диалог открытия файла, чтобы не вводить имена файлов вручную.
  • Многострочный текст - поле для редактирования длинных строк. Поддерживается перенос слов и перевод строк.

Значение по умолчанию

Значение для автоматического заполнения поля при добавлении новой записи. Это может быть любая строка. Поддерживаются макросы, например, если ввести строку "$Hour$:$Minute$:$Second$", то при добавлении новой записи поле в этом столбце уже будет заполнено текущим временем. См. макросы.

Запрещать пустые значения

Если опция включена, то программа не разрешит добавить или заменить запись, пока значение в поле не будет заполнено.

Запрещать повторяющиеся значения

Значение должно быть уникальным в столбце. Пустые значения могут повторяться, даже если эта опция включена.

Формула

Это поле появляется только для виртуальных столбцов. Формула позволяет выводить в столбце значения, вычисленные на основе значений из других столбцов. См. формулы.

См. также
Меню - Сервис - Таблица - Столбцы


Сервис - Таблица - Информация

В окне отображаются следующие сведения: название таблицы, полное имя файла, размер сохраненного файла, дата и время последнего сохранения файла, количество записей в таблице, статус (редактирование, просмотр, изменено). Используя команды Копировать все и Сохранить в файл... из всплывающего меню можно соответственно скопировать в буфер или сохранить в файл всю информацию, отображаемую в окне.

См. также
Меню - Сервис - Таблица


Сервис - Таблица - Опции

Каждая таблица может иметь свои собственные опции, отличные от других таблиц. Например, разрешены ли в таблице повторяющиеся записи. Чтобы просмотреть или изменить эти опции, выберите команду Таблица... в меню Сервис , а затем выберите категорию Опции. В окне будут доступны следующие опции таблицы:

Разрешать пустые записи

Разрешить добавлять записи, все поля в которых пустые.

Запрещать повторяющиеся записи

Запретить добавление новой записи, если в таблице уже есть точно такая же запись (т.е. все значения в соответствующих столбцах совпадают учетом регистра символов). Эта опция не действует на пустые записи.

Вставлять новые записи в начало списка

По умолчанию все новые записи добавляются в конец списка. Обычно при включении этой опции также включают запрещение сортировки.

Не отсекать крайние пробелы для значений

По умолчанию программа автоматически удаляет пробелы, которые пользователь может ввести слева или справа от каждого значения записи.

Запретить сортировку

Эту опцию рекомендуется включить, если порядок следования записей в таблице важен и из-за сортировки может быть нарушен. Опция действует только на страницу Все в главном окне программы. На страницах Найденные и Выбранные сортировка останется доступной.

Некоторые из перечисленных опций действуют при добавлении новых записей, но не проверяют уже добавленные записи. Например, если для таблицы, где есть повторяющиеся записи, включить опцию Запрещать повторяющиеся записи, то программа не удалит повторяемые записи и даже не сообщит об их существовании. Некоторые из перечисленных опций действуют и на добавление группы записей из файла (через команду Сервис - Импорт...). По умолчанию для новых таблиц все перечисленные опции отключены.

Кнопка Пароль... служит для установки пароля на таблицу.

См. также
Меню - Сервис - Таблица


Сервис - Таблица - Опции - Пароль

Установка пароля на таблицу поможет скрыть ваши данные от других пользователей. Будьте крайне внимательны и осторожны, ведь введенный пароль программа не сохраняет на компьютере. Забытый пароль не сможет восстановить даже автор программы. Вы можете использовать пароль на свой страх и риск.

Таблица, защищенная паролем, сохраняется в зашифрованном виде. Поэтому её можно будет открывать только через данную программу, но нельзя будет открыть в других редакторах (например, в Excel). Вводить пароль нужно будет при каждом открытии таблицы. В данной версии шифруется только CSV-файл, а GG-файл не шифруется, поэтому другим пользователям могут быть доступны настройки столбцов и опции таблицы.

Чтобы снять пароль с таблицы, нужно открыть это же окно, ввести текущий пароль, а вместо нового пароля оставить пустые значения.

См. также
Меню - Сервис - Таблица - Опции


Разное - Командная строка

Программа "ТаблицаПро" поддерживает следующие ключи запуска:

Ключ | Описание
"C:\My Tables\My File.csv" | Открытие указанного файла. Желательно указывать полный путь к файлу. Если в строке есть пробелы, то строку нужно "обернуть" кавычками.
Title="Просмотр отчета" | Так можно изменять название программы.
Options="C:\My Tables\Options2.xml" | Так можно указать программе, откуда читать и куда сохранять настройки программы.
Read | Запретить редактирование открываемых таблиц.
Single | Запретить открывать другие таблицы кроме той, что указана в командной строке.
Simplest | Скрыть всё меню.
NoTable | Не показывать команду Таблица... в меню Сервис.
NoOptions | Не показывать команду Параметры... в меню Сервис.
NoHelp | Запретить использование справки.
NoAbout | Не показывать команду О программе...


Разное - Файлы

Программа загружает и сохраняет таблицы в файлах с расширением CSV (Comma Separated Values). CSV-файлы - это обычные текстовые файлы, данные в которых разделены некоторым символом. Чаще всего это "," (запятая) или ";" (точка с запятой). Программа умеет автоматически определять, какой символ используется в файле для разделения данных (программа также определяет символы Tab и "|"). При сохранении таблицы используется тот разделитель, который указан в параметрах программы.

CSV-файлы можно открывать и во многих других редакторах (например, в Excel'е или в обычном Блокноте).

Т.к. CSV-файл может хранить только значения из ячеек таблицы, то для каждой таблицы программа создает дополнительный файл с именем таблицы и расширением GG. В таких файлах сохраняются настройки столбцов и опции таблиц. GG-файлы можно редактировать с помощью стандартного Блокнота (файлы имеют xml-структуру).


Разное - Формулы

Начиная с версии 3.25, программа поддерживает вычисления по формулам. Виртуальные столбцы отображают в себе значения, которые вычисляются по формулам на основе значений из других столбцов. Например, если в таблице "Продажи" есть столбцы "Товар", "Цена" и "Количество", то может быть добавлен виртуальный столбец "Стоимость", который просто будет отображать цену, умноженную на количество.

Как выглядят формулы

7+8
2-(100*4+8-(6*15-3/4))/177
10/(#1*#2)
"Name="+UpperCase(#1)
If(#3="";"Column3 is empty";"Column3="+#3)
If(And(#4<>"";#5<>"");Round(If(#6="";#4*#5;#4*#5/100*(100-#6));2);"")

Ссылки

Формулы оперируют над полями каждой записи в отдельности, нельзя для расчета значения в одной ячейке записи обратиться к значениям другой записи. Для обращения к полям записи используется номер столбца с указанием перед ним символа "#". Например, формула #1*#2 означает: значение из первого столбца умножить на значение из второго.

Типы данных

В формулах поддерживаются только два типа данных: числа и строки. Типы времени и даты не поддерживаются. Логический тип заменен на числовой (нулевое значение означает ложь, а все остальные - истина). Типы в формулах преобразуются автоматически. По умолчанию считается, что в ячейках таблицы находятся строки, а не числа. Поэтому, чтобы сложить значения в двух столбцах, формулы #1+#2 будет недостаточно. Программа просто сцепит эти значения как строки (т.е. "100" плюс "15" получится "10015"). Здесь нужно принудительно преобразовать в число тип данных в первом аргументе: Val(#1)+#2, тогда программа поймет, что значения нужно складывать как числа.

Правила написания формул

Имена методов можно писать в любом РеГиСтРе. Можно вставлять пробелы - они игнорируются. Строки должны обрамляться двойными кавычками. Если нужно использовать двойные кавычки внутри строк, то кавычки нужно продублировать: "What is ""TablePro""?". Аргументы в методах можно перечислять только через ";" (например Max(#1;#2)).

Методы

Методы | Описание
+ Сцепление двух строк либо сложение двух чисел. Определяется по типу первого аргумента. Если значения нужно сложить как числа, а аргументы являются ссылками на другие столбцы, то первый аргумент должен быть преобразован в число методом Val.
- Разность двух чисел.
* Умножение двух чисел.
/ Деление двух чисел.
> Сравнение двух чисел. Возвращает 1, если неравенство верно, иначе 0.
>= Сравнение двух чисел. Возвращает 1, если неравенство верно, иначе 0.
< Сравнение двух чисел. Возвращает 1, если неравенство верно, иначе 0.
<= Сравнение двух чисел. Возвращает 1, если неравенство верно, иначе 0.
= Сравнение двух чисел или строк. Возвращает 1, если неравенство верно, иначе 0.
<> Сравнение двух чисел или строк. Возвращает 1, если неравенство верно, иначе 0.
If(условие;истина;ложь) | Проверяет условие в первом аргументе и возвращает второй (если условие верно) либо третий (если условие неверно, т.е. равно 0). Например, формула If(1<2;"Yes";"No") вернет "Yes", а формула If(1=2;1000;5000) вернет 5000.
Str(число) | Преобразует число в строку.
Val(строка) | Преобразует строку в число.
Max(число;число...)
Min(число;число...) 		Возвращает максимальное/минимальное значение из перечисленных в скобках. Можно указать от 2 до 256 значений.
Length(строка) | Возвращает длину строки (количество символов). Например, Length("Plintus") вернет 7.
Not(условие) | Преобразует условие к противоположному (если был 0, то станет 1, иначе 0).
And(условие;условие...) | Проверяет, чтобы все условия были верны.
Or(условие;условие...) | Проверяет, чтобы хотя бы одно из условий было верно.
UpperCase(строка)
LowerCase(строка) 		Преобразует строку к верхнему/нижнему регистру.
Trim(строка) | Удаляет из строки крайние пробелы, если они есть. Можно также использовать TrimLeft(строка) или TrimRight(строка) для удаления пробелов только в начале или в конце строки.
Copy(строка;индекс;количество) | Возвращает часть строки, от символа с указанным индексом (первый символ в строке имеет индекс 1) длиной с указанным количеством символов. Можно также использовать CopyLeft(строка;количество) или CopyRight(строка;количество) для копирования от начала или от конца строки.
Delete(строка;индекс;количество) | Удаляет из строки указанный интервал символов. Можно также использовать DeleteLeft(строка;количество) или DeleteRight(строка;количество) для удаления символов от начала или от конца строки. Например, Delete("Plintus";4;2) вернет "Plius", а DeleteRight("Plintus";3) вернет "Plin".
Insert(строка;строка;индекс) | Вставляет первую строку во вторую строку в указанную позицию. Например, Insert("nt";"Plius";4) вернет "Plintus".
Repeat(строка;количество) | Повторить строку указанное количество раз. Например, Repeat("Plintus";3) вернет "PlintusPlintusPlintus".
Round(число[;число]) | Округление числа до целого. Если указан второй необязательный аргумент, то округление до указанного количества знаков после точки или запятой. Например, Round(-123.456;2) вернет -123.45, а Round(-123.456) вернет -123.
Pos(строка;строка) | Возвращает индекс символа, с которого начинается первая строка во второй. Если первая строка во второй отсутствует, то возвращает 0. Например, Pos("nt";"Plintus") вернет 4. Поиск осуществляется с учетом регистра.
Cos(число)
Sin(число) 		Возвращает косинус/синус числа.
Sqr(число)
Sqrt(число) 		Возвращает квадрат/корень числа.
Int(число) | Возвращает целую часть числа.
Abs(число) | Возвращает модуль числа.
Pi | Возвращает 3.1415926535897932385.
Sign(число) | Возвращает знак числа (-1,0,+1).
Power(число1;число2) | Возводит число в степень.
Reverse(строка) | Разворачивает строку. Например, Reverse("Plintus") вернет "sutnilP".
Format(строка;число) | Выводит число в формате, который задан строкой. Например, Format("#,##0.00", -1654332.7) вернет "-1,654,332.70".
Char(строка;индекс) | Возвращает символ строки по указанному индексу. Первый символ в строке имеет индекс 1.
LineCount(строка) | Возвращает количество строк в многострочном тексте.
Line(строка;индекс) | Возвращает строку по указанному индексу в многострочном тексте. Первая строка имеет индекс 1.
Replace(строка;строка2;строка3) | Находит в строке, которая указана первой, строку2 и заменяет ее на строку3. Например, Replace("PlintusPlintus";"tus";"ka") вернет "PlinkaPlintus". Можно также использовать ReplaceAll(строка;строка2;строка3) для замены всех вхождений. Например, ReplaceAll("25-0-19";"-";"") вернет "25019". Поиск осуществляется с учетом регистра.
PosCount(строка;строка) | Возвращает количество вхождений первой строки во вторую. Поиск осуществляется с учетом регистра. Например, PosCount("a";"Anapa") вернет 2, а PosCount("a";LowerCase("Anapa")) вернет 3.

Коды ошибок

В формулах возможны два вида ошибок: ошибки написания формулы (например, не закрыта скобка) и ошибки при вычислении формулы (например, деление на ноль).

Коды ошибок | Описание
41 | Неизвестный метод. Возможно, имя метода написано с ошибкой.
42 | Неизвестный символ. Возможно, используются апострофы вместо двойных кавычек при указании строки.
43 | Закрывающих скобок больше, чем открывающих. Или закрывающая скобка находится до открывающей.
44 | Открывающих скобок больше, чем закрывающих.
45 | Не найден конец строки, т.е. открывающая двойная кавычка есть, а закрывающей нет.
46 | Неверная структура формулы. Например, идут подряд два знака умножения, или знак деления сразу после открывающей скобки.
47 | Неверная запись числа.
48 | Неверная запись ссылки на столбец.
49 | Слишком мало аргументов в методе.
50 | Слишком много аргументов в методе.
81 | Общая (неизвестная) ошибка вычисления.
82 | Циклическая ссылка. Например, есть ссылка виртуального столбца на самого себя.
83 | Указанный столбец не найден. Например, использована ссылка на столбец #6, а в таблице всего пять столбцов.
84 | Деление на ноль.
85 | Неверный тип аргумента. Например, в методе, которому в качестве аргумента требуется число, вставлена строка.
86 | Переполнение числа, число слишком большое для вычислений.
87 | Переполнение числа, число слишком маленькое для вычислений.
88 | Переполнение целого числа. Например, компьютер не может округлить слишком большое число с плавающей точкой до целого.
89 | Неверная операция над числами с плавающей точкой.


Разное - Ограничения

В программе действуют следующие ограничения:

Свойства | Ограничения
Минимальное количество невиртуальных столбцов | 1
Максимальное количество столбцов (в т.ч. виртуальных) | 256
Максимальное количество записей | более 536 млн.
Минимальная ширина столбца (пикс.) | 7
Максимальная ширина столбца (пикс.) | 1 000
Максимальное количество списков в истории результатов поиска | 32
Объем истории быстрого поиска | 32
Максимальное количество пунктов в ниспадающих списках | 600
Максимальный размер одного поля записи (симв.) | более 65 000
Максимальное количество аргументов в методах формул | 256


Разное - Макросы

Начиная с версии 3.20, программа поддерживает макросы. Макросы могут быть использованы при экспорте (в предлагаемом имени файла), а также в свойствах столбца (в свойстве Значение по умолчанию). Например, значение "$Year$" программа будет заменять текущим годом. Поддерживаются следующие замены:

  • $Date$ - текущая дата.
  • $Time$ - текущее время.
  • $Year$ - текущий год.
  • $Month$ - текущий месяц.
  • $Day$ - сегодняшний день.
  • $Hour$ - час.
  • $Minute$ - минута.
  • $Second$ - секунда.

Строка "Сейчас $Hour$ часов $Minute$ минут" заменяется на текущее время (например, "Сейчас 14 часов 07 минут"). Строка "$Year$/$Month$/$Day$" заменяется на текущую дату (например, "2009/11/31"). И т.д.

См. также
Меню - Сервис - Столбцы - Изменить
Меню - Сервис - Параметры - Экспорт


Разное - Программы

На сайте http://zgsprojects.narod.ru вы найдете и другие мои программы, среди которых:

Добрый молодец - веселая игра с прохождением уровней

Сахалинская колония - экономическая пошаговая стратегия

Шашки - всем известная игра

Локардо - Лото + Карты + Домино

City - редактор географических карт

Записная книжка - всегда под рукой!

Копировщик - утилита для резервного копирования файлов


Разное - Сочетания клавиш

Большинство действий в программе можно выполнить без использования мыши. Ниже приведен список сочетаний клавиш, действующих в главном окне программы:

Команды меню

Действия | Клавиши
Файл - Новый... | Ctrl+N
Файл - Открыть... | Ctrl+O
Файл - Выбрать таблицу... | F4
Файл - Сохранить | Ctrl+S
Файл - Закрыть | Ctrl+Q
Файл - Выход | F10
Запись - Добавить... | F5
Запись - Изменить... | Enter
Запись - Удалить | Del
Запись - Быстрый поиск... | F3
Запись - Обычный поиск... | Ctrl+F
Запись - Расширенный поиск... | Ctrl+W
Запись - Все - Выбрать все | Shift+Ins
Запись - Найденные - Очистить список | Ctrl+L
Запись - Выбранные - Вернуть все | Ctrl+Ins
Запись - Выбрать/вернуть | Ins
Запись - Показать | Ctrl+G
Сервис - Таблица... | Ctrl+T
Сервис - Экспорт... | Ctrl+E
Сервис - Печать... | Ctrl+P
Сервис - Операции... | Ctrl+R
Сервис - Параметры... | Ctrl+Y
Вызов справки | F1

Скрытые команды

Действия | Клавиши
Добавить запись как копию выделенной... | Shift+F5
Вставить запись перед выделенной... | Alt+F5
Показать предыдущий результат поиска | Shift+Ctrl+B
Показать следующий результат поиска | Shift+Ctrl+N
Печать текущей выделенной записи | Shift+Ctrl+P
Авторазмер по всем столбцам | Shift+Ctrl+A
Упорядочить записи по статусу | Shift+Ctrl+S
Переместить запись выше/ниже | Shift+Ctrl+Up, Shift+Ctrl+Down
Переместить запись в начало/конец списка | Shift+Ctrl+Home, Shift+Ctrl+End
Переместить выбранные записи выше/ниже | Shift+Ctrl+Alt+Up, Shift+Ctrl+Alt+Down
Переместить выбранные записи в начало/конец списка | Shift+Ctrl+Alt+Home, Shift+Ctrl+Alt+End
Перейти к следующей/предыдущей найденной записи | Ctrl+Down, Ctrl+Up

Другие

Действия | Клавиши
Открыть страницу Все | Ctrl+1
Открыть страницу Найденные | Ctrl+2
Открыть страницу Выбранные | Ctrl+3
Переключение между страницами | Tab
Показать меню страницы | Ctrl+Пробел
Выделение в таблице вверх | Up, PgUp, Home
Выделение в таблице вниз | Down, PgDown, End
Прокрутка таблицы по горизонтали | Left, Right